aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5e6f18..15486f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,8 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON) # For Kate's LSP
find_package(QT NAMES Qt5 REQUIRED COMPONENTS Widgets Concurrent)
find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets Concurrent)
+find_package(mastodonpp REQUIRED)
+
# add_subdirectory will happen later…
set(PROJECT_SOURCES
src/main.cpp
@@ -38,6 +40,10 @@ set(PROJECT_SOURCES
src/list_item.h
src/command_line.cpp
src/command_line.h
+ src/net/instance.cpp
+ src/net/instance.h
+ src/net/mastodon_instance.cpp
+ src/net/mastodon_instance.h
src/activitypub/fields.h
src/activitypub/apactivity.h
src/activitypub/apactor.h
@@ -81,6 +87,7 @@ else()
endif()
target_link_libraries(ActorViewer PRIVATE Qt${QT_VERSION_MAJOR}::Widgets)
+target_link_libraries(ActorViewer PUBLIC mastodonpp)
set_target_properties(ActorViewer PROPERTIES
MACOSX_BUNDLE_GUI_IDENTIFIER space.twilightsparkle.ActorViewer