aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2023-08-24 18:43:15 -0400
committerConfuSomu2023-08-24 19:35:58 -0400
commit9c60bc8ce4a0990c228d2cd746791b88c41532b8 (patch)
treef6e7d56422f95f8202980a87866f0d798c199f47 /CMakeLists.txt
parente625d3fcca7c735ed98570bc1acbcaa840541e61 (diff)
downloadActorViewer-9c60bc8ce4a0990c228d2cd746791b88c41532b8.tar
ActorViewer-9c60bc8ce4a0990c228d2cd746791b88c41532b8.tar.gz
ActorViewer-9c60bc8ce4a0990c228d2cd746791b88c41532b8.zip
Implement basic Mastodon API support
Implement support for OAuth 2.0 code entry, which is then used to retrieve a token that is stored in the application's settings. Authentification allowed the implementation of a basic "get post from URL" feature mostly made for testing.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5e6f18..15486f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,8 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON) # For Kate's LSP
find_package(QT NAMES Qt5 REQUIRED COMPONENTS Widgets Concurrent)
find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets Concurrent)
+find_package(mastodonpp REQUIRED)
+
# add_subdirectory will happen later…
set(PROJECT_SOURCES
src/main.cpp
@@ -38,6 +40,10 @@ set(PROJECT_SOURCES
src/list_item.h
src/command_line.cpp
src/command_line.h
+ src/net/instance.cpp
+ src/net/instance.h
+ src/net/mastodon_instance.cpp
+ src/net/mastodon_instance.h
src/activitypub/fields.h
src/activitypub/apactivity.h
src/activitypub/apactor.h
@@ -81,6 +87,7 @@ else()
endif()
target_link_libraries(ActorViewer PRIVATE Qt${QT_VERSION_MAJOR}::Widgets)
+target_link_libraries(ActorViewer PUBLIC mastodonpp)
set_target_properties(ActorViewer PROPERTIES
MACOSX_BUNDLE_GUI_IDENTIFIER space.twilightsparkle.ActorViewer