aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2023-06-10 18:53:35 -0400
committerConfuSomu2023-06-10 18:59:30 -0400
commit7e4c7905c9e74d76de2e03413af0dc9e4cb84683 (patch)
treeca0de8ab135ecc9af006664b5f505c0e2415de5a /CMakeLists.txt
parentd3d14e07c202f9350f817802777720ded85e4248 (diff)
downloadActorViewer-7e4c7905c9e74d76de2e03413af0dc9e4cb84683.tar
ActorViewer-7e4c7905c9e74d76de2e03413af0dc9e4cb84683.tar.gz
ActorViewer-7e4c7905c9e74d76de2e03413af0dc9e4cb84683.zip
Implement command line options
Implementing a command line argument specifying the data export to open allows iterating faster as the file to open can be specified without navigating through a GUI. In the future, more command line options could be specified to specify the view filters for instance.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7360a52..9c6381c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,8 @@ set(PROJECT_SOURCES
src/types.h
src/list_item.cpp
src/list_item.h
+ src/command_line.cpp
+ src/command_line.h
)
if(${QT_VERSION_MAJOR} GREATER_EQUAL 6)