aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2021-02-15 11:06:57 -0500
committerConfuSomu2021-02-15 11:06:57 -0500
commitf2d591ce164086cdb0e57a49e867058e59457795 (patch)
tree1d4d44005e9e886a1cea52e9b808450bd74be478 /CMakeLists.txt
parent93341511201aca2daf10c26f8b1f5c0bf13e669c (diff)
downloadpico-watch-f2d591ce164086cdb0e57a49e867058e59457795.tar
pico-watch-f2d591ce164086cdb0e57a49e867058e59457795.tar.gz
pico-watch-f2d591ce164086cdb0e57a49e867058e59457795.zip
Implement home menu
Buttons are now detected and reported to the current running application (demoed in main_clock and home_menu with `oledWriteString(oled, 0,0,2, &data[0], FONT_6x8, 0, 1);`). I start to see the limitations with APP_DATA. It will be dropped in a futur commit after moving each app into its own namespace. Variables will be allocated dynamically on app init.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9e2c8b..0b9aa59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,8 @@ add_executable(pico-watch
init.h
buttons.c
buttons.h
+ apps/home_menu.c
+ apps/home_menu.h
apps/main_clock.c
apps/main_clock.h
)