summaryrefslogtreecommitdiffstats
path: root/pkg-config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pkg-config/CMakeLists.txt')
-rw-r--r--pkg-config/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkg-config/CMakeLists.txt b/pkg-config/CMakeLists.txt
new file mode 100644
index 0000000..4640f17
--- /dev/null
+++ b/pkg-config/CMakeLists.txt
@@ -0,0 +1,7 @@
+include(GNUInstallDirs)
+
+configure_file("${PROJECT_NAME}.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc" @ONLY)
+
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc"
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")