summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d56a9d..5bc30ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@ project(mastodonpp
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
# Project build options.
-# option(WITH_TESTS "Compile tests." NO)
+option(WITH_TESTS "Compile tests." NO)
# option(WITH_DOC "Generate HTML documentation." YES)
# option(WITH_EXAMPLES "Compile examples." NO)
# option(WITH_DEB "Prepare for the building of .deb packages." NO)
@@ -32,8 +32,8 @@ include(debug_flags)
add_subdirectory(src)
-# if(WITH_TESTS)
-# add_subdirectory(tests)
-# endif()
+if(WITH_TESTS)
+ add_subdirectory(tests)
+endif()
# include(cmake/packages.cmake)