aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2023-08-03 17:23:33 +0200
committerConfuSomu2023-08-03 17:23:33 +0200
commitbf73a19e11e5cccd22f58a5c97e1346dab5587c8 (patch)
tree64654503131a2eb77c5e9cbf25478330e8ce261b /CMakeLists.txt
parent1500681405804b932761db7a0182d498894ad81c (diff)
downloadActorViewer-bf73a19e11e5cccd22f58a5c97e1346dab5587c8.tar
ActorViewer-bf73a19e11e5cccd22f58a5c97e1346dab5587c8.tar.gz
ActorViewer-bf73a19e11e5cccd22f58a5c97e1346dab5587c8.zip
Create an Archive base class
This class is inherited by MastodonArchive to provide Mastodon (and compatible) archive reading support. A base Archive class allows implementing reading support of other archive formats that are from other services.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d28f320..2d09544 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,8 +24,10 @@ set(PROJECT_SOURCES
src/finddialog.cpp
src/finddialog.h
src/finddialog.ui
- src/archive_parser.cpp
- src/archive_parser.h
+ src/archive/base_archive.cpp
+ src/archive/base_archive.h
+ src/archive/mastodon.cpp
+ src/archive/mastodon.h
src/types.h
src/list_item.cpp
src/list_item.h