aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2023-11-12 00:16:02 -0500
committerConfuSomu2023-11-12 00:16:02 -0500
commit8ee7a379bbd8c1e2d7831208308bf11eabcdc79d (patch)
tree601b9d6e453d0be1acc7a56a3df6f233cc4a73da /CMakeLists.txt
parent80a658f062328ab8b47dc6b2557d274f51278b3a (diff)
downloadActorViewer-8ee7a379bbd8c1e2d7831208308bf11eabcdc79d.tar
ActorViewer-8ee7a379bbd8c1e2d7831208308bf11eabcdc79d.tar.gz
ActorViewer-8ee7a379bbd8c1e2d7831208308bf11eabcdc79d.zip
Move status info widget to its own widget
It is responsable of processing list items which are given to it, via signals, and then displaying them on the interface. Making this widget separate and modular will allow creating more advanced status views that aren't only HTML-based and that are more intuitive to use.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15486f5..8aa19f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,9 @@ set(PROJECT_SOURCES
src/settingsdialog.ui
src/settings_interface.cpp
src/settings_interface.h
+ src/widgets/status_info.cpp
+ src/widgets/status_info.h
+ src/widgets/status_info.ui
src/archive/base_archive.cpp
src/archive/base_archive.h
src/archive/mastodon.cpp