aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2023-07-18 00:00:20 +0200
committerConfuSomu2023-07-18 00:00:20 +0200
commit5ed7d9b53a65aec1f4793f62ac15195c44224b39 (patch)
tree20f59b643ab185abc8eeecb6338d565ed36febda /CMakeLists.txt
parente322946df7c33f76dbee46ec5b8e2118fbae8a26 (diff)
downloadActorViewer-5ed7d9b53a65aec1f4793f62ac15195c44224b39.tar
ActorViewer-5ed7d9b53a65aec1f4793f62ac15195c44224b39.tar.gz
ActorViewer-5ed7d9b53a65aec1f4793f62ac15195c44224b39.zip
Implement Question object type support
This commit adds support for dealing with ActivityPub Questions, which are polls. They are like Notes (posts) but contain a few more keys that record information about the poll options, number of votes and poll closure date.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7bcbe6e..5bab400 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ set(PROJECT_SOURCES
src/list_item.h
src/command_line.cpp
src/command_line.h
+ src/activitypub/fields.h
src/activitypub/apactivity.h
src/activitypub/apactor.h
src/activitypub/apattachment.h
@@ -35,6 +36,7 @@ set(PROJECT_SOURCES
src/activitypub/apobject.h
src/activitypub/appost.h
src/activitypub/apreblog.h
+ src/activitypub/apquestion.h
src/activitypub/apactivity.cpp
src/activitypub/apactor.cpp
src/activitypub/apattachment.cpp
@@ -42,6 +44,7 @@ set(PROJECT_SOURCES
src/activitypub/apobject.cpp
src/activitypub/appost.cpp
src/activitypub/apreblog.cpp
+ src/activitypub/apquestion.cpp
)
if(${QT_VERSION_MAJOR} GREATER_EQUAL 6)