aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2023-07-10 13:27:34 +0200
committerConfuSomu2023-07-10 13:42:16 +0200
commit5befd0666aef0b96e3e4bd41ed704ccaa3ace5d5 (patch)
tree76402efb62ecf9bc1817910179afc7f71b646e32 /CMakeLists.txt
parent9b70e3c5a208a881188bc6468fe27933cbdb02f8 (diff)
downloadActorViewer-5befd0666aef0b96e3e4bd41ed704ccaa3ace5d5.tar
ActorViewer-5befd0666aef0b96e3e4bd41ed704ccaa3ace5d5.tar.gz
ActorViewer-5befd0666aef0b96e3e4bd41ed704ccaa3ace5d5.zip
Implement basic multithreading support
A few CPU heavy operations, which are opening an archive and displaying a selected Activity, have been moved to another thread to avoid having long-running operations on the main thread.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0994a9..7bcbe6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,8 +12,8 @@ set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_EXPORT_COMPILE_COMMANDS ON) # For Kate's LSP
-find_package(QT NAMES Qt5 REQUIRED COMPONENTS Widgets)
-find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets)
+find_package(QT NAMES Qt5 REQUIRED COMPONENTS Widgets Concurrent)
+find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets Concurrent)
# add_subdirectory will happen later…
set(PROJECT_SOURCES