aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConfuSomu2024-01-03 19:20:26 +0100
committerConfuSomu2024-01-03 19:20:26 +0100
commit5511c195766de625bf6c4bf39950940814c27aad (patch)
treeddf2033b0d9ceb47e7177aa551705ec088af2a2f /CMakeLists.txt
parent00cea51b0b9431b1952cd9f771dc59f7b5de99a0 (diff)
downloadActorViewer-5511c195766de625bf6c4bf39950940814c27aad.tar
ActorViewer-5511c195766de625bf6c4bf39950940814c27aad.tar.gz
ActorViewer-5511c195766de625bf6c4bf39950940814c27aad.zip
Move activity list to a tab widget
This allows us to have more tabs in the future with additional information, such as information about the Actor or even other activity views. This commit was quite a lot of work and refactoring!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8aa19f2..c5daebf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,9 @@ set(PROJECT_SOURCES
src/widgets/status_info.cpp
src/widgets/status_info.h
src/widgets/status_info.ui
+ src/widgets/tab_activity_list.cpp
+ src/widgets/tab_activity_list.h
+ src/widgets/tab_activity_list.ui
src/archive/base_archive.cpp
src/archive/base_archive.h
src/archive/mastodon.cpp
@@ -89,8 +92,7 @@ else()
endif()
endif()
-target_link_libraries(ActorViewer PRIVATE Qt${QT_VERSION_MAJOR}::Widgets)
-target_link_libraries(ActorViewer PUBLIC mastodonpp)
+target_link_libraries(ActorViewer PRIVATE Qt${QT_VERSION_MAJOR}::Widgets mastodonpp)
set_target_properties(ActorViewer PROPERTIES
MACOSX_BUNDLE_GUI_IDENTIFIER space.twilightsparkle.ActorViewer